Author Topic: Upgraded to PHP 5.4  (Read 5736 times)

0 Members and 1 Guest are viewing this topic.

Xepher

  • Techsmith
  • Administrator
  • *****
  • Posts: 4,288
  • Illegitimis non carborundum!
    • View Profile
    • Xepher.net
Upgraded to PHP 5.4
« on: October 15, 2012, 02:22:47 am »
The server has been upgraded to PHP 5.4.6 (from 5.3.15) and other minor software bits were upgraded as well. As usual, if you run into problems, please let me know.

Miluette

  • Sr. Member
  • ****
  • Posts: 332
  • C:
    • View Profile
    • Miluette dot com
Re: Upgraded to PHP 5.4
« Reply #1 on: October 15, 2012, 04:04:52 am »
Got this error on my websites that use a particular piece of code: Fatal error: Call to undefined function import_request_variables() in /home/millennium/public_html/mil/lp_source.php on line 4 (I took out the poll code to fix it in the meantime)

There's also a bunch of errors popping up on Xepher.net's main page.

I wonder if we can get notice for PHP updates.
« Last Edit: October 15, 2012, 04:08:57 am by Miluette »
And wasn't it you who told me,
"The sun would always chase the day"?

Xepher

  • Techsmith
  • Administrator
  • *****
  • Posts: 4,288
  • Illegitimis non carborundum!
    • View Profile
    • Xepher.net
Re: Upgraded to PHP 5.4
« Reply #2 on: October 15, 2012, 07:46:53 am »
I think I've fixed the main page errors. My code had some obsolete functions in it that I needed to update. Mainly, check that a variable exists before using it. For the error you were getting, this page explains that it's been removed in php 5.4  http://php.net/manual/en/function.import-request-variables.php As this was removed from PHP since it's a large security issue (since it's basically a replacement for the horribly insecure "register_globals") it's not something I'm likely to revert. I'd suggest you find a new poll plugin that doesn't rely on this, or see if there's an updated version. That said, there are some suggestions in the comments on that page for using extract() to replace the functionality, but I'd really advise against that (for the aforementioned security issues.) I do apologize for the trouble though. Hopefully it won't be too big of a pain to replace. If you have more trouble too, just let me know.

Miluette

  • Sr. Member
  • ****
  • Posts: 332
  • C:
    • View Profile
    • Miluette dot com
Re: Upgraded to PHP 5.4
« Reply #3 on: October 15, 2012, 03:54:16 pm »
It's actually not a huge deal -- especially since, once I removed the poll, I didn't see any other errors on the page -- so that's OK! I am soon to be updating my major sites to Wordpress anyway (in one huge overhaul), so they won't need that old poll widget at all.

Thanks for keeping things up to date!
And wasn't it you who told me,
"The sun would always chase the day"?