Xepher.Net Forums

Community => Knowhow Trading Post => Topic started by: Miluette on June 12, 2009, 01:43:56 am

Title: Wordpress 2.8
Post by: Miluette on June 12, 2009, 01:43:56 am
I upgraded to it, and it broke that one comic's archives. (Which is odd, since I upgraded on another site and nothing happened.)

I come up with either a blank screen for everything in the admin area, or this error mooshes all over my site:

Quote
Fatal error: Cannot use object of type WP_Error as array in /home/millennium/public_html/lf/pages/wp-includes/category.php on line 137

Yay. Any other Xepher site experience this? I might know why, but even when I know, it doesn't make sense, since other sites with my exact same setup upgraded fine.
Title: Re: Wordpress 2.8
Post by: fesworks on June 12, 2009, 02:30:45 am
I don't auto-upgrade to WordPress any more.. not without backing up the site.

I believe Webcomic+Inkblot 2.0 are ready compatible with WordPress 2.8 anyway... but I tend to wait a while anyway, just to be sure.

So, in other word, I have not had a problem... but I bet you are using ComicPress... yeah, you never wanna update WordPress until you know for sure that a ComicPress and CP Manager is upgraded first and works.

You may want to try and downgrade your site.

Link to TWCL forum on the same subject:
http://www.thewebcomiclist.com/forums/viewtopic.php?t=6457

EDIT: of which you've posted, and said are not using ComicPress... try talking to "mgsisk" on AIM (Webcomic+Inkblot guy), but I though he said 2.0 was compatible...

In any case, I am using an older mark-up of Webcomic+Inkblot... and have not upgraded... so it seems I won;t be for a while :P
Title: Re: Wordpress 2.8
Post by: Miluette on June 12, 2009, 03:26:11 am
Yeah, I'm using WebComic + Inkblot. XD And Wordpress 2.8 only worked when I disabled WebComic, which doesn't help as it's the reason I have WP in the first place.

WP2.8 seemed to be acting oddly on LF's archives even when I disabled WebComic too, so screw it. c__c I'll wait until WP2.8 gets to like...2.8.1 or WebComic updates again or something.

I was talking to Mike (I bother him a lot ;x;`) and he was baffled. I like how I've been able to completely baffle him with things (most of which are most assuredly my or WP's fault). XD If you can't replicate an error though, that's what happens. I'm using WebComic 2 and InkBlot 2, and others were able to upgrade just fine, but not me. But that's fine, 'cause there's nothing wrong with WP2.7.1 and apparently 2.8 isn't much better, lol.

So yeah I downgraded WP and things work again.
Title: Re: Wordpress 2.8
Post by: fesworks on June 12, 2009, 05:08:20 am
I was talking to Mike (I bother him a lot ;x;`) and he was baffled. I like how I've been able to completely baffle him with things (most of which are most assuredly my or WP's fault). XD If you can't replicate an error though, that's what happens. I'm using WebComic 2 and InkBlot 2, and others were able to upgrade just fine, but not me. But that's fine, 'cause there's nothing wrong with WP2.7.1 and apparently 2.8 isn't much better, lol.

So yeah I downgraded WP and things work again.

Yea, I bother him all the time too :P

My Inkblot is heavily edited too (actually, PSI and Ardra are custom jobs I paid Mike to do :P )
Title: Re: Wordpress 2.8
Post by: Databits on June 12, 2009, 02:57:13 pm
That error isn't really a super-major issue. If the developers can't figure something that obvious out, I'm a little sad.

It's what back traces are good for. :P
Title: Re: Wordpress 2.8
Post by: Miluette on June 15, 2009, 10:52:06 pm
DB, I already know you have ridiculously high standards. I've seen people complain about this same error that aren't even using comic plugins.

Mike found out what was causing the error in the case of WebComic users. Something in WebComic conflicting with something weird in WP2.8 - no idea why it's doing that but it really shouldn't be. A temporary fix was commenting out a line that was for an optional setting. We can only hope a future upgrade of WP changes whatever generates the category.php error. :O
Title: Re: Wordpress 2.8
Post by: Xepher on June 15, 2009, 11:12:03 pm
I had another report of a tokenizer error happening, as it was trying to use a function that wasn't in the local PHP here. I've rebuilt PHP with tokenizer support, so that'll fix that one at least.
Title: Re: Wordpress 2.8
Post by: Databits on June 16, 2009, 11:19:41 am
Hey, my standards aren't ridiculously high... they're expectant that people who wish to program do so properly. :( Those who half-ass things are the ones who put the good programmers out of work (and end up making things that later get hacked and lose 4 million credit card numbers in the process because they don't know what they are doing).
Title: Re: Wordpress 2.8
Post by: griever on June 16, 2009, 12:12:05 pm
THANK YOU, XEPHER!  That was me.  I reported it on WP's forums with several other people.  I actually had noticed that in RC1 prior to June 10th, but I assumed it was an error on their part.  I rarely try out anything except the stable releases, but 2.7's obsession with autosaves was driving me up the wall.  It clogged up my tables. :(