The anti-spam plugins have stopped being effective. Registration is back to requiring approval. After registering, you must ALSO email me with your username, so that I can manually approve your account.

Main Menu

file permissions

Started by robynie, June 09, 2006, 04:00:42 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I got lazy and I've started using Website Baker to make my website.  After every time I change something I go and use the fix file permissions tool and everything was working fine.  Except it stopped working.  Now I have one page that still gives the "internal server error" even after using the fix file permissions tool.  I even tried manually setting the file permissions using my FTP client.

Any ideas?


It would help if you tell me which file is still having the problem, so I can look at it myself. :-)


Oh, I meant to include that, sorry.

It's what you get if you click on "Slow going" or the read more of that news post.


Hmm... two problems here at least. First off, my fix permissions script doesn't like that filename. That many dots is making it think it's a "....php" file, instead of a ".php" file. I'm fixing that as we speak, so that's done. Now that works, the file just returns "no input file specified" which is an error in your scripts somewhere. My guess is that they ALSO dislike that many dots at the end of a filename. Lemme go look into that...

EDIT: Confirmed. If you rename the file without all the extra dots it works fine. I tried to hunt through the code, but I don't know where it's actually generating that error at, as it's quite convoluted. As such, I'd suggest you simply avoid ending any post titles with a string of periods. Either that, or bug whoever actually wrote it. :-)



You may be able to write it into an .htaccess file to execute that specific file as php.
(\_/)    ~Relakuyae D'Selemae
(")_(")  [Libre Office] [Chrome]


No need to play with .htaccess files... My script just wasn't catching it with the right extention, so it wasn't setting the proper permissions on it. It was trival to manually set 700 on it, and then it executed fine. Plus, as I said, I fixed my "fix" script. :-)

Now the only issue is one in the code itself not dealing with that filename well.


Well I just changed the name of the post.  I can deal with not ending headlines with ... !