Author Topic: Automated Email Rules  (Read 21556 times)

0 Members and 1 Guest are viewing this topic.

Miluette

  • Sr. Member
  • ****
  • Posts: 332
  • C:
    • View Profile
    • Miluette dot com
Re: Automated Email Rules
« Reply #15 on: August 17, 2008, 08:25:11 pm »
Okay, I did a bit more testing.

I signed up two accounts on my forum using both my main emails. No activation emails for either of them. No approval notice for anyone who's signed up recently, either.

No one's been able to retrieve their passwords via email from my forum nor my oekaki (the oekaki I left to manual approval by me). Whenever I approve an account for the oekaki, it also says "an email could not be sent" (I assume to notify them). I thought there was an SMTP setting for the oekaki, but I can't find it, so maybe not.
And wasn't it you who told me,
"The sun would always chase the day"?

Xepher

  • Techsmith
  • Administrator
  • *****
  • Posts: 4,325
  • Illegitimis non carborundum!
    • View Profile
    • Xepher.net
Re: Automated Email Rules
« Reply #16 on: August 18, 2008, 08:58:02 am »
for the forum, you've got the wrong smtp host... you have "millenium@xepher.net" when it should be just "localhost" Try changing that, then test the forum. I'm still sorting the problems with the oekaki.

Xepher

  • Techsmith
  • Administrator
  • *****
  • Posts: 4,325
  • Illegitimis non carborundum!
    • View Profile
    • Xepher.net
Re: Automated Email Rules
« Reply #17 on: August 18, 2008, 10:24:32 am »
I think I've finally got it sorted. The oekaki is calling the PHP mail() function, rather than directly calling sendmail. PHP however, is trying to call sendmail with USER=root, so it's trying to find the .esmtprc file in /root/ instead of /home/millennium/ It used to work correctly, but now it doesn't. Bizarre. I've written a wrapper script that I HOPE will fix the problem. In my own testing it seems to, as I can now use a php script to send an email to my gmail account, as well as local xepher.net addresses. Try it on the oekaki, and see if mail goes through now.

My apologies, in that I didn't realize this had broken recently. Several other people used that with their php scripts to send mail, and it was working, so I just assumed it was more likely an issue with how you'd configured things, not realizing that they'd stopped using it in the mail() method. So in conclusion... My bad! :-P

Miluette

  • Sr. Member
  • ****
  • Posts: 332
  • C:
    • View Profile
    • Miluette dot com
Re: Automated Email Rules
« Reply #18 on: August 19, 2008, 08:58:43 pm »
Woo! Both things work now. <33
And wasn't it you who told me,
"The sun would always chase the day"?

Xepher

  • Techsmith
  • Administrator
  • *****
  • Posts: 4,325
  • Illegitimis non carborundum!
    • View Profile
    • Xepher.net
Re: Automated Email Rules
« Reply #19 on: August 20, 2008, 06:59:41 am »
Yay! Problem solved!

Xepher

  • Techsmith
  • Administrator
  • *****
  • Posts: 4,325
  • Illegitimis non carborundum!
    • View Profile
    • Xepher.net
Re: Automated Email Rules
« Reply #20 on: February 25, 2009, 10:36:29 am »
New DNS blacklist has been enabled for outgoing email. If you send mail through the server, and you get rejected because it was in the spamhaus blacklist, let me know. Be sure to include the time/date of the mail you tried to send so I can check logs.