The anti-spam plugins have stopped being effective. Registration is back to requiring approval. After registering, you must ALSO email me with your username, so that I can manually approve your account.

Main Menu

Why would some people have a problem downloading a Netcast?

Started by fesworks, December 14, 2007, 10:04:35 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I just now tried downloading the new one... using this exact link and it downloaded at 850KB/s or so, taking about 40 seconds and resulting in a full/complete file. It's 3pm in the afternoon here, which according to the logs, is right in the busiest time of the day for the site. Note that I just moved, so this is a new ISP as well. At my previous location the downloads went about 350KB/s or so (because that ISP only offered speeds about that high), and completed just fine as well. Just for kicks I just tried episode 12, using the link provided above by Desh... it likewise goes 800KB/s+ and finished in about 40 seconds. I'm using firefox (on linux though.)

It seems like when people are having problems, they're obviously getting really low speeds. I'm gonna download things a few times using a throttled download, see if it dies or chokes after a bit.

EDIT: Good news... kinda. I can reproduce the problem, I ran several throttled downloads, and even though they started at different times, and were running completely different speeds, both died at almost exactly 5 minutes after starting (like 7 seconds off.) That's too much of a coincidence to not be some coded limit. Now to find it...


Okay, I think I found it... there was a per-child expiration timeout that defaults to 5 minutes for some stupid reason. I believe it was originally designed to kill a child server process when it hadn't been USED for 5 minutes or more, but as I've kept my configs from before, now it seems to mean 5 minutes total lifespan. I tried lowering it to 90 seconds and the downloads started dieing right around that mark instead, so I'm pretty confident this is the culprit. I've raised it to 3 hours now, which should be enough even for someone on dial up to get a podcast almost twice the size the Beacon is averaging. I'm currently downloading it at a throttled 10K, and it's been going for more than three times as long as any previous attempt, and still coming through just fine. Lemme know if it works for you guys now.

Also, sorry (especially to Fes) that it took me so long to find this and figure it out. Until today, none of the reports seemed to have anything in common... all seemingly dieing at different spots for different people. The 5 minutes total time finally tipped me off. The other limits (ones I'd intentionally put in place) are all based on actual resources consumed, so they might limit to 5 minutes CPU time, but even an hour long download barely uses 2 seconds of CPU time. This was the first time I was aware that this setting/limit uses total wall-time to determine when to kill things. Anyway, my fault that I didn't read the documentation better when I setup the new server I guess... I still get to blame everyone's ISPs for the slow downloads they were getting that triggered this though. :-P


I downloaded it just fine now - same speed and same time but the file comes out complete.  No idea why I could download an mp3 from my site with about the same speed/size...maybe it was 4:59 and I just got lucky. ^_^
"You can get all A's and still flunk life." (Walker Percy)


Just got all of Beacon 13 at around 30-50kb/s with no problems :D



Thanks very much! I'll modify our next show to mention the good news! (albeit not in greek ;) and directed to ISP's faults :P )


No worries... I kid about blaming the ISPs. I just meant to say that the slow speeds aren't a server side problem, even though the cut-offs were.