Author Topic: Website rendering issues between different browsers  (Read 7635 times)

0 Members and 1 Guest are viewing this topic.

~Christopher

  • Newbie
  • *
  • Posts: 10
  • The Ace Of Hearts
    • View Profile
    • My deviantART page
Website rendering issues between different browsers
« on: January 09, 2009, 03:31:56 am »
Okay so I've started to build my website (http://little-infinity.xepher.net/~Chris/)

It's going well. As you see, I'm more of a graphic person than a code person, so I decided to make the code simple.

It looks great in Firefox 1/2/3 (preferrably under 1280x1024 screen resolution, but lower ones shouldn't affect it much)

The problem is. Once you switch over to IE7, (see for yourself). All that appears is the middle iFrame (which has alot of unneeded scrollbars). The background image doesn't even appear properly. And none of the image hotspots are there.

I don't get this it all, the code is really nothing complex. It's an iframe within an iframe. Could somebody please take a look to see if the problem appears on your IE browsers too?

I'll post screenies if you guys need to see what I mean.

Thanks!
~Christopher

deviantART | OCAD

sagebrush

  • Jr. Member
  • **
  • Posts: 76
  • cat pirate princess
    • View Profile
    • Crowfeathers
Re: Website rendering issues between different browsers
« Reply #1 on: January 09, 2009, 09:23:06 am »
Question:  Why do you have nested iframes?

You can check it here: http://validator.w3.org/

Mainly it seems upset about not having the doctype defined.

griever

  • Sr. Member
  • ****
  • Posts: 457
    • View Profile
Re: Website rendering issues between different browsers
« Reply #2 on: January 09, 2009, 02:07:19 pm »
Why won't the code on main.htm work?  Do you need nested iframes?  I'm on a mac so I can't see but the code on your main.htm stuff looks pretty solid to me.
"You can get all A's and still flunk life." (Walker Percy)

~Christopher

  • Newbie
  • *
  • Posts: 10
  • The Ace Of Hearts
    • View Profile
    • My deviantART page
Re: Website rendering issues between different browsers
« Reply #3 on: January 09, 2009, 02:47:14 pm »
Well, I checked my main.htm and defined the doctype, but the issue still persists.

http://validator.w3.org/check?uri=http%3A%2F%2Flittle-infinity.xepher.net%2F~Chris%2F&charset=(detect+automatically)&doctype=Inline&group=0

There are tons of other errors, but I don't see what's wrong because I used the same code for my other project (http://little-infinity.xepher.net/~spreadthelove) and it works fine.....

Is it just because IE just hates nested iFrames?

What baffles me more is that Firefox (despite all those errors shown) renders the site perfectly fine. I have yet to test it in Safari, but I will later.
« Last Edit: January 09, 2009, 02:49:12 pm by ~Christopher »
~Christopher

deviantART | OCAD

Databits

  • Global Moderator
  • *****
  • Posts: 1,607
  • Programming's not just a science, it's an art.
    • View Profile
Re: Website rendering issues between different browsers
« Reply #4 on: January 09, 2009, 03:51:01 pm »
Possibly, the W3 validation will not help you with IE. IE never follows the full rules. In either case, you shouldn't be using nested iframes anyhow.
(\_/)    ~Relakuyae D'Selemae
(o.O)    
(")_(")  [Libre Office] [Chrome]

~Christopher

  • Newbie
  • *
  • Posts: 10
  • The Ace Of Hearts
    • View Profile
    • My deviantART page
Re: Website rendering issues between different browsers
« Reply #5 on: January 09, 2009, 08:30:52 pm »
EDIT: Well I really got everything to work.....I am so stupid.... -_-

The real problem was the fact that I accidentally rescaled the main.png image to 781 pixels instead of it's actual 804, so that really threw crap off.


Ahh okay.

Well I seemed to have fixed the stupid issue with IE. For the main.png,

<img src="main.png" width="1084" border="0" height="" usemap="#FPMap0">

Yeah, I was stupid and forgot to supply a height value (FF and Safari seem to assume that if nothing is entered then the height is defined by the height of the image itself, IE does not) :P

There's still a problem with IE though. It adds scrollbars to the frame on main.htm when they ARE NOT needed (screwing up the alignment of the frame or something).

I tested it in Safari just now, and it works perfectly. Same with older versions of FF. It's just stupid IE.

The world should really ditch IE. It's annoying. Anyways if you guys can't help me with the scrollbars, that's fine. It's not a big issue now that I fixed the main.png.

Anyways thanks for the help sofar!
« Last Edit: January 09, 2009, 09:23:20 pm by ~Christopher »
~Christopher

deviantART | OCAD

amuletts

  • Newbie
  • *
  • Posts: 31
  • Epic Fail
    • View Profile
    • Epic Fail
Re: Website rendering issues between different browsers
« Reply #6 on: January 23, 2009, 04:12:16 pm »
Glad you got it fixed.