The anti-spam plugins have stopped being effective. Registration is back to requiring approval. After registering, you must ALSO email me with your username, so that I can manually approve your account.

Main Menu

Mysterious Firefox Phenomena

Started by Miluette, February 14, 2009, 12:53:02 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Firefox does weird things. Both versions, Windows and Mac. Apart from using up 95-99% of my CPU within fifteen minutes to half an hour of opening it (which I won't fault it too hard for, as it seems even Chrome and Safari does this now and much more annoyingly, ugh), it does things sometimes like not showing me images on pages, when the images are definitely linked correctly.

In fact, I can go directly to the image URL and it'll load up fine, but on pages they won't show at all. I can look at the image under Page Info and it'll be like: broken! This has happened with a select few of my own hosted pictures on my own websites, and a few from Photobucket... they show up in other browsers. c_c
And wasn't it you who told me,
"The sun would always chase the day"?


I think it could either be the browser or even the server itself. If the site is running on a Linux server, some images might not show up because the server is case-sensitive and can't read them. Learned that the hard way myself when I tried running on a Linux server. I think Mac servers do this too, I'm not sure. Also, Firefox itself may be case-sensitive, but I really don't know about that. Hope that helps.


Sounds fishier than just case problems. If it's chewing up all the CPU, that's usually flash applets gone awry, though I've seen it with add-ons sometimes too. The broken images thing... that's trickier to hunt down. If it's doing it on more sites than just your own, then it's not likely to be a server issue. I'd say start by disabling all add-ons, clear your cache and cookies, and see if that helps.


Actually, this is due to the way some of these browsers write to the disk cache. I notice this too on both my laptop and desktop from time to time (less on my desktop since it has a significantly faster disk though). It has something to do with waiting for all current disk cache write operations to complete before it writes or something like that. I don't recall the details... I also thought that was fixed.
(\_/)    ~Relakuyae D'Selemae
(")_(")  [Libre Office] [Chrome]


I had that problem, but it stopped last time I updated Firefox...


FF seems to be less horrible since I added 3.1 beta 3 to my PC! But I also haven't tried to run AIM, Photoshop, and Sai simultaneously with it yet, either.
And wasn't it you who told me,
"The sun would always chase the day"?