Author Topic: Welcome to Arclight!  (Read 26368 times)

0 Members and 1 Guest are viewing this topic.

Xepher

  • Techsmith
  • Administrator
  • *****
  • Posts: 4,325
  • Illegitimis non carborundum!
    • View Profile
    • Xepher.net
Welcome to Arclight!
« on: November 11, 2007, 12:49:48 pm »
If you're reading this, you're on the new server,  code-named "Arclight" which is a Core2 Duo system with 2GB of ram and nearly a full terabyte of hard drive space. It's also being hosted on a 100mbit link (the old server was 5mbit) so things should be faster all around. All user accounts should be migrated and working by now, but this was a complex process, so if you're having issues with something, don't hesitate to bring it to my attention. You can post in the forum (aka reply here), email me, or contact me on AIM (my SN is "Xepher42" there.) Welcome to Arclight!

Xepher

  • Techsmith
  • Administrator
  • *****
  • Posts: 4,325
  • Illegitimis non carborundum!
    • View Profile
    • Xepher.net
Re: Welcome to Arclight!
« Reply #1 on: November 11, 2007, 12:59:36 pm »
Everyone should go login to user services at https://xepher.net/user-services/ and double-check your settings/info. You can also upload banner images to replace the ugly text ones that are currently rotating in the newsbox. Don't forget you've got to use the new password you set during the account renewal.

If you're using email and had asked for it to be imported from the old server... rest assured all email is intact. If you're missing email folders, go to the "subscribe to folders" option in your email client (or webmail) and you should see your "missing" folders there.

Everyone using email needs to pay close attention to the "Unsure" and "Junk" folders to start with. All mail will be delivered to "Unsure" until your spam filter is trained. You train it by moving messages out of Unsure and into the appropriate folder. That is, move spam into "Junk" and it's learned as Junk... move it to your Inbox (or any custom folder you've created... pretty much anything but "Trash") and it will be learned as good (non-spam) email. As the filter learns, it will start delivering only good email to your inbox, and deliver all the spam to "Junk." But you have to watch it to start with, to make sure it doesn't mis-identify some legit email as Junk to start with. That said, check both the Junk and Unsure folders regularly until you're confident the filter is trained well.

FTP is now gone. You must use SCP/SFTP to upload files.

If you're having any other problems, contact me as mentioned in the first post.

Xepher

  • Techsmith
  • Administrator
  • *****
  • Posts: 4,325
  • Illegitimis non carborundum!
    • View Profile
    • Xepher.net
Re: Welcome to Arclight!
« Reply #2 on: November 11, 2007, 01:24:22 pm »
Having some trouble with incoming email... I'll let you know when it's fixed.

EDIT: It's fixed now.

FYI: If you're using email and have a domain linked to your account here, mail will be rejected for any emails at that domain until you set the appropriate alias(es) in user services.
« Last Edit: November 11, 2007, 01:41:59 pm by Xepher »

Xepher

  • Techsmith
  • Administrator
  • *****
  • Posts: 4,325
  • Illegitimis non carborundum!
    • View Profile
    • Xepher.net
Re: Welcome to Arclight!
« Reply #3 on: November 11, 2007, 10:52:36 pm »
There are DNS issues screwing things up right now. Only "xepher.net" itself is affected, all other domains and all subdomains should work properly. Just the main site is gonna have issues. What happened is that the root nameservers somehow have a direct A record for "xepher.net" pointing to the old IP. They're NEVER supposed to have that, but the registrar I've used for years had a slightly broken system way back when, and I managed to do something stupid with it before I knew better, and now the system checks for those sorts of mistakes and so it won't let me reverse-break it. :-P

I have an email into the registrar's support staff, but we'll see how long it takes them to respond. If it's not on it's way to solved by the time I wake up (I'm going to bed now), I'm gonna hack around it somehow.

Xepher

  • Techsmith
  • Administrator
  • *****
  • Posts: 4,325
  • Illegitimis non carborundum!
    • View Profile
    • Xepher.net
Re: Welcome to Arclight!
« Reply #4 on: November 12, 2007, 09:01:59 am »
Well, no response at all from my registrar, and it's still broken. I am so annoyed with this, it's a stupid problem I had years ago with them (last time the server moved) and I thought it would've been fixed by now.

Anyway, I've hacked around it a bit for now, by using the old server to proxy requests to the new one, so most stuff should work as expected now, it just may be a tad slower for urls starting with "http://xepher.net" only... any other domain or subdomain should be connecting directly (as they have correct dns.) There's probably a few bits here and there that will be quirky because of it, notably if you log into anything secure (https) like user-services, it'll warn you it's connecting to "www.xepher.net" when the certificate is only for "Xepher.net" but it's still safe to continue. If I don't hear back from these people soon, I'm gonna think about transferring registrars to someone that at least has a phone number. It amazes how what was a legit business years ago seems to be a shady operation these days.

EDIT: Note that the proxy only applies to the web... if you're trying to connect to scp/sftp and having trouble, try "www.xepher.net" instead of just "xepher.net" for now.
« Last Edit: November 12, 2007, 09:33:04 am by Xepher »

griever

  • Sr. Member
  • ****
  • Posts: 457
    • View Profile
Re: Welcome to Arclight!
« Reply #5 on: November 12, 2007, 11:42:55 am »
Looks nice!  I double-checked my information, changed my password in the config file, and everything's running smoothly for me again.  ^_^  I like the banner system!
"You can get all A's and still flunk life." (Walker Percy)

Xepher

  • Techsmith
  • Administrator
  • *****
  • Posts: 4,325
  • Illegitimis non carborundum!
    • View Profile
    • Xepher.net
Re: Welcome to Arclight!
« Reply #6 on: November 12, 2007, 12:46:55 pm »
Glad to hear it!

I've put a bunch of rewrites/redirects around, so it should hopefully move everything from "xepher.net" to "www.xepher.net" for the time being. If you have an issue anywhere that the servername 'xepher.net" is directly used, try putting in "www.xepher.net" instead. This should only be temporary, until I get a registrar to fix their problem.

On that note... anyone not just curious can skip the rest of the this post.

I dig some more digging and I've found where the problem is. Internic (the organization in charge of the entire world-wide DNS system) has "xepher.net" listed as a NAMESERVER, meaning they have a direct record for it and it's IP address... That was the mistake that got made years ago. Problem is, my registrar -- through whom I'm supposed to be able to edit/update/remove nameserver listings -- has no record of it being a nameserver, and thus, no way for me to edit it. Trying to add it as a new nameserver was my first idea, hoping that it would force an update/override the old settings. But that fails, as it (now correctly) won't let you create a nameserver directly on a root domain. I've got another email off to my registrar's upstream provider (turns out I bought from a reseller, oops) and they seem much more likely to respond. Hopefully I'll hear something today about this and get this issue settled once and for all.

Witchiebunny

  • Newbie
  • *
  • Posts: 40
  • Now in three new witchier flavors
    • View Profile
    • http://www.hiddendisguises.com
Re: Welcome to Arclight!
« Reply #7 on: November 12, 2007, 01:04:39 pm »
that hack seems to have worked, I can actually log into the forums now! :D

Any issues I had have all been cleared up, thanks!

deltha

  • Newbie
  • *
  • Posts: 18
    • View Profile
Re: Welcome to Arclight!
« Reply #8 on: November 12, 2007, 02:40:36 pm »
Core2Duo... mmmm.. nice  ;D. But is something different for those not in phase 2 (like me :) ) ?. Mail, ssh & mysql doesn't work for me. Thanks

pigeon-wing

  • Jr. Member
  • **
  • Posts: 56
    • View Profile
    • http://suku.xepher.net
Re: Welcome to Arclight!
« Reply #9 on: November 12, 2007, 05:00:05 pm »
So I can't use SSH with the new system?

Edit: Nevermind, I just had to add "www." to the host name.

Everything's working fine for me now. I love the new banner system :)
« Last Edit: November 12, 2007, 05:08:09 pm by pigeon-wing »
I'm so sorry about Bella, Jack.

Slang

  • Newbie
  • *
  • Posts: 23
  • Fly on, Littlewing
    • View Profile
    • Tripout Designs
Re: Welcome to Arclight!
« Reply #10 on: November 12, 2007, 07:38:05 pm »
The no more FTP is a huge bummer. I just fixed my program too. =(

poop.
"It is better to fail in originality than to succeed in imitation."
-Herman Melville

pigeon-wing

  • Jr. Member
  • **
  • Posts: 56
    • View Profile
    • http://suku.xepher.net
Re: Welcome to Arclight!
« Reply #11 on: November 12, 2007, 08:02:26 pm »
The no more FTP is a huge bummer. I just fixed my program too. =(

poop.

Databits' tutorial is so easy to follow, though :) I converted right after I read through it.
I'm so sorry about Bella, Jack.

Slang

  • Newbie
  • *
  • Posts: 23
  • Fly on, Littlewing
    • View Profile
    • Tripout Designs
Re: Welcome to Arclight!
« Reply #12 on: November 12, 2007, 08:44:36 pm »
It's not taking my password >> & something about the host being down.
I'll try it later =\
Though thankya' Pigeon-wing


edit: fixed by adding the www
« Last Edit: November 13, 2007, 03:57:18 am by Slang »
"It is better to fail in originality than to succeed in imitation."
-Herman Melville

TheTwinNex

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Welcome to Arclight!
« Reply #13 on: November 13, 2007, 06:24:13 am »
Ohgosh I decided to check my site tonight before bed and the new server basically ate the layout. Uh oh. I'm thinking it would just be permissions or something. Unfortunately I don't have the time to really look into it, but this new system is looking pretty nice. I can't wait to toy around with it a bit and see what I can do.

Xepher

  • Techsmith
  • Administrator
  • *****
  • Posts: 4,325
  • Illegitimis non carborundum!
    • View Profile
    • Xepher.net
Re: Welcome to Arclight!
« Reply #14 on: November 13, 2007, 07:40:38 am »
Deltha... no, it should work the same for all users. Are you using your new password? The one you set on the renewal form? It's now your main password and your database password, so you may have to edit any scripts that use mysql to use the new password. Also, as noted above... "xepher.net" directly doesn't work right now, so change it to "www.xepher.net" and see if that helps. If that doesn't work, let me know specifically what you're trying to use/do and any/all errors you get.